1232 畅通工程

Problem Description

某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路?

Input

测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。
注意:两个城市之间可以有多条道路相通,也就是说
3 3
1 2
1 2
2 1
这种输入也是合法的
当N为0时,输入结束,该用例不被处理。

Output

对每个测试用例,在1行里输出最少还需要建设的道路数目。

Sample Input

1
2
3
4
5
6
7
8
9
10
11
12
4 2
1 3
4 3
3 3
1 2
1 3
2 3
5 2
1 2
3 5
999 0
0

Sample Output

1
2
3
4
5
6
7
1
0
2
998

HintHint
Huge input, scanf is recommended.

Suggest Answer

就是并查集,要建设的道路就是集合数-1

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
import java.util.*;

public class _1232 {
public static void main(String[] args) {
Scanner input = new Scanner(System.in);
int N = input.nextInt();
while (N != 0) {
int[] set = new int[N + 1];
int count = -1;
for (int i = 1; i <= N; i++) {
set[i] = i;
}
int M = input.nextInt();
for (int i = 0; i < M; i++) {
int x = input.nextInt();
int y = input.nextInt();
merge(set, x, y);
}
for (int i = 1; i <= N; i++) {
if (set[i] == i) {
count++;
}
}
System.out.println(count);
N = input.nextInt();
}
}

public static int find(int[] set, int num) {
int i = num;
while (set[i] != i) {
i = set[i];
}
return i;
}

public static void merge(int[] set, int x, int y) {
int fx = find(set, x);
int fy = find(set, y);
if (fx != fy) {
set[fx] = fy;
}
}
}